The PCI DSS 3.0 has been released but merchants are not ready to upgrade.

As readers of this blog are well aware, point of sale software solutions are vulnerable to malware and fraud. Having the right security systems in place is crucial for any retailer, and with the new Payment Card Industry Data Security Standard (PCI DSS) 3.0 being released, every merchant should be looking into the security of their POS equipment.

Business have until January 1, 2014 to get up to speed, which is good because a new study found that many in the retail industry have not yet incorporated basic security requirements of the PCI DSS.

Conducted by the Ponemon Institute, the study found that 47 percent of organizations have no risk-based security management programs in place. On top of that, nearly half of respondents describe their risk-based security strategy as “non-existent” and only 29 percent have a consistent strategy across the entire company.

“On the whole, organizations are making slow progress with deployment of risk-based security management strategies and programs,” the report concluded. “Given the increase in organizational commitment and the understanding that risk-based security management can align security with key business, organizations appear poised to make more significant strides over the next 12 to 18 months.”

Security can become a complicated process that can confuse any organization and lead to a breach. This is where a retail solution provider that understands the importance of a secure point of sale system can become a valuable resource for any organization that is looking to improve its operations and keep its solutions safe from criminals. For comprehensive protection for your business, contact Visual Retail Plus, we have special features integrated into our POS system for security. Be sure and ask how you can download our free demo today!